summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 4e57228..8c427d3 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -10,7 +10,7 @@
# If you do not have access to either file, you may request a copy from
# help@hdfgroup.org.
#
-#
+#
# This makefile mostly just reinvokes make in the various subdirectories
# but does so in the correct order. You can alternatively invoke make from
# each subdirectory manually.
@@ -31,17 +31,20 @@ endif
if BUILD_CXX_CONDITIONAL
CXX_DIR = c++
endif
-
if BUILD_TESTS_CONDITIONAL
TEST_DIR = test
else
TEST_DIR =
endif
if BUILD_TOOLS_CONDITIONAL
+if BUILD_TOOLS_HL_CONDITIONAL
TOOLS_DIR = tools
else
TOOLS_DIR =
endif
+else
+ TOOLS_DIR =
+endif
## Don't recurse into any subdirectories if HDF5 is not configured to
## use the HL library