summaryrefslogtreecommitdiffstats
path: root/hl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/Makefile.am')
-rw-r--r--hl/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/hl/Makefile.am b/hl/Makefile.am
index 4e6db6a..1f016b5 100644
--- a/hl/Makefile.am
+++ b/hl/Makefile.am
@@ -24,6 +24,10 @@ if BUILD_CXX_CONDITIONAL
CXX_DIR = c++
endif
-SUBDIRS=src test $(CXX_DIR) $(FORTRAN_DIR)
+## Don't recurse into any subdirectories if HDF5 is not configured to
+## use the HL library
+if BUILD_HDF5_HL_CONDITIONAL
+ SUBDIRS=src test $(CXX_DIR) $(FORTRAN_DIR)
+endif
include $(top_srcdir)/config/conclude.am