summaryrefslogtreecommitdiffstats
path: root/hl/c++/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/c++/Makefile.am')
-rw-r--r--hl/c++/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/hl/c++/Makefile.am b/hl/c++/Makefile.am
index a2d4315..e19cab2 100644
--- a/hl/c++/Makefile.am
+++ b/hl/c++/Makefile.am
@@ -20,5 +20,17 @@
include $(top_srcdir)/config/commence.am
SUBDIRS=src test
+DIST_SUBDIRS=src test examples
+
+# Install examples
+install-examples uninstall-examples:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
+# Check that examples can be successfully built
+check-install:
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
+
+installcheck-local:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
include $(top_srcdir)/config/conclude.am