summaryrefslogtreecommitdiffstats
path: root/hl/c++/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/c++/examples/Makefile.am')
-rw-r--r--hl/c++/examples/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/hl/c++/examples/Makefile.am b/hl/c++/examples/Makefile.am
new file mode 100644
index 0000000..85cb35e
--- /dev/null
+++ b/hl/c++/examples/Makefile.am
@@ -0,0 +1,48 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+#
+# HDF5 Library Examples Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# These are the programs that 'make all' or 'make prog' will build and
+# which 'make check' will run. List them in the order they should be run.
+TEST_PROG=ptExampleFL ptExampleVL
+
+# These are the example files to be installed
+INSTALL_FILES=ptExampleFL.cpp ptExampleVL.cpp
+
+# Tell conclude.am that these are C++ tests.
+HDF_CXX=yes
+
+# Where to install examples
+EXAMPLEDIR=$(docdir)/hdf5/examples/hl/c++
+
+# How to build programs using h5c++
+$(EXTRA_PROG): $(LIBHDF5) $(LIBH5CPP) $(LIBH5CPP_HL)
+ $(H5CPP) $(CPPFLAGS) -o $@ $(srcdir)/$@.cpp
+
+# List dependencies for each program. Normally, automake would take
+# care of this for us, but if we tell automake about the programs it
+# will try to build them with the normal C++ compiler, not h5c++. This is
+# an inelegant way of solving the problem, unfortunately.
+ptExampleFL: ptExampleFL.cpp
+ptExampleVL: ptExampleVL.cpp
+
+include $(top_srcdir)/config/examples.am
+include $(top_srcdir)/config/conclude.am