summaryrefslogtreecommitdiffstats
path: root/hl/c++/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/c++/src/Makefile.am')
-rw-r--r--hl/c++/src/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/hl/c++/src/Makefile.am b/hl/c++/src/Makefile.am
new file mode 100644
index 0000000..9e44c23
--- /dev/null
+++ b/hl/c++/src/Makefile.am
@@ -0,0 +1,40 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5-C++ Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src directory
+INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src
+
+# Build the library statically because some compliers can only link one
+# dynamic library, and that's the main hdf5 library (which is much larger
+# than this one).
+AM_LDFLAGS=-static
+
+# This is our main target
+lib_LTLIBRARIES=libhdf5_hl_cpp.la
+
+# Source files for the library
+# At the moment, only the H5PT Packet Table has a C++ API.
+libhdf5_hl_cpp_la_SOURCES=H5PacketTable.cpp
+
+# Public headers
+include_HEADERS=H5PacketTable.h
+
+include $(top_srcdir)/config/conclude.am