summaryrefslogtreecommitdiffstats
path: root/hl/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/examples/Makefile.am')
-rw-r--r--hl/examples/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/hl/examples/Makefile.am b/hl/examples/Makefile.am
index a98e4a5..df3a8ad 100644
--- a/hl/examples/Makefile.am
+++ b/hl/examples/Makefile.am
@@ -43,10 +43,11 @@ TEST_PROG = ex_lite1 ex_lite2 ex_lite3 ptExampleFL ptExampleVL \
INSTALL_FILES = ptExampleFL.c ptExampleVL.c
# Additional dependencies for each program are listed below.
-$(EXTRA_PROG): $(LIBHDF5) $(LIBH5_HL)
if BUILD_PARALLEL_CONDITIONAL
+$(EXTRA_PROG): $(H5CC_PP)
$(H5CC_PP) $(CFLAGS) -o $@ $(srcdir)/$@.c;
else
+$(EXTRA_PROG): $(H5CC)
$(H5CC) $(CFLAGS) -o $@ $(srcdir)/$@.c;
endif