summaryrefslogtreecommitdiffstats
path: root/hl/fortran/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/Makefile.am')
-rw-r--r--hl/fortran/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/hl/fortran/Makefile.am b/hl/fortran/Makefile.am
index 306176c..e6de85e 100644
--- a/hl/fortran/Makefile.am
+++ b/hl/fortran/Makefile.am
@@ -25,5 +25,17 @@
include $(top_srcdir)/config/commence.am
SUBDIRS=src test
+DIST_SUBDIRS=src test
+
+# Install examples
+install-examples uninstall-examples:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
+
+# Check that examples can be successfully built
+check-install:
+ @$(MAKE) $(AM_MAKEFLAGS) installcheck
+
+installcheck-local:
+ @(cd examples && $(MAKE) $(AM_MAKEFLAGS) $@) || exit 1;
include $(top_srcdir)/config/conclude.am