summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 994ccaa..cca6147 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -14,12 +14,12 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/hl/src -I$(top_builddir)/hl/src
AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
+# Fortran libraries are linked statically to solve a build problem.
+AM_LDFLAGS=-static
+
# Our main target, the high-level fortran library
lib_LTLIBRARIES=libhdf5hl_fortran.la
-# Fortran library is linked statically to solve a build problem.
-libhdf5hl_fortran_la_LDFLAGS=-static
-
# Source files for the library
if BUILD_PARALLEL_CONDITIONAL
PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90