summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index 9153247..994ccaa 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -17,6 +17,9 @@ AM_FFLAGS=-I$(top_builddir)/fortran/src $(F9XMODFLAG)$(top_builddir)/fortran/src
# Our main target, the high-level fortran library
lib_LTLIBRARIES=libhdf5hl_fortran.la
+# Fortran library is linked statically to solve a build problem.
+libhdf5hl_fortran_la_LDFLAGS=-static
+
# Source files for the library
if BUILD_PARALLEL_CONDITIONAL
PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90