summaryrefslogtreecommitdiffstats
path: root/hl/fortran/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/src/Makefile.am')
-rw-r--r--hl/fortran/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/fortran/src/Makefile.am b/hl/fortran/src/Makefile.am
index d4fec65..f872a63 100644
--- a/hl/fortran/src/Makefile.am
+++ b/hl/fortran/src/Makefile.am
@@ -45,9 +45,13 @@ endif
# PARALLEL_COND_SRC=HDFDmpiof.c HDF5mpio.f90
#endif
+# List sources to include in the HDF5 HL Fortran library.
libhdf5hl_fortran_la_SOURCES=H5LTfc.c H5IMfc.c H5IMcc.c H5TBfc.c H5LTff.f90 \
H5IMff.f90 H5TBff.f90
+# HDF5 HL Fortran library depends on HDF5 HL Library and HDF5 Fortran Library.
+libhdf5hl_fortran_la_LIBADD=$(LIBH5_HL) $(LIBH5F)
+
# Fortran module files can have different extensions and different names
# (e.g., different capitalizations) on different platforms. Write rules
# for them explicitly rather than trying to teach automake about them.