summaryrefslogtreecommitdiffstats
path: root/hl/fortran/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/test/CMakeLists.txt')
-rw-r--r--hl/fortran/test/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/hl/fortran/test/CMakeLists.txt b/hl/fortran/test/CMakeLists.txt
index b4f4075..2968943 100644
--- a/hl/fortran/test/CMakeLists.txt
+++ b/hl/fortran/test/CMakeLists.txt
@@ -12,6 +12,20 @@ LINK_DIRECTORIES (
${CMAKE_LIBRARY_OUTPUT_DIRECTORY}
)
+# Remove any output file left over from previous test run
+ADD_TEST (
+ NAME hl_fortran_test-clear-objects
+ COMMAND ${CMAKE_COMMAND}
+ -E remove
+ dsetf1.h5
+ dsetf2.h5
+ dsetf3.h5
+ dsetf4.h5
+ dsetf5.h5
+ f1image.h5
+ f1tab.h5
+)
+
#-- Adding test for hl_f90_tstlite
ADD_EXECUTABLE (hl_f90_tstlite tstlite.f90)
H5_NAMING (hl_f90_tstlite)