summaryrefslogtreecommitdiffstats
path: root/hl/fortran/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/fortran/test/Makefile.am')
-rw-r--r--hl/fortran/test/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/hl/fortran/test/Makefile.am b/hl/fortran/test/Makefile.am
new file mode 100644
index 0000000..cff6351
--- /dev/null
+++ b/hl/fortran/test/Makefile.am
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2001 National Center for Supercomputing Applications.
+# All rights reserved.
+#
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+##
+#
+# HDF5 High-Level Fortran Makefile(.in)
+
+include $(top_srcdir)/config/commence.am
+
+AM_CPPFLAGS=-I$(top_srcdir)/src $(top_builddir)/src
+AM_FFLAGS=-I$(top_builddir)/fortran/src -I$(top_builddir)/hl/fortran/src -M$(top_builddir)/fortran/src -M$(top_builddir)/hl/fortran/src
+
+# Our main target, the test programs
+TEST_PROG=tstlite tstimage tsttable
+check_PROGRAMS=$(TEST_PROG)
+
+LDADD=$(LIBH5_HL) $(LIBH5F_HL) $(LIBH5F) $(LIBHDF5)
+
+# Source files for the programs
+tstlite_SOURCES=tstlite.f90
+tstimage_SOURCES=tstimage.f90
+tsttable_SOURCES=tsttable.f90
+
+include $(top_srcdir)/config/conclude.am