summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
new file mode 100644
index 0000000..adbe00a
--- /dev/null
+++ b/hl/src/Makefile.am
@@ -0,0 +1,24 @@
+# Copyright (C) 2001 National Center for Supercomputing Applications.
+# All rights reserved.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 High-Level Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Add include directories to the C preprocessor flags
+#AM_CPPFLAGS=-I. -I$(srcdir) -I$(top_builddir)/src -I$(top_srcdir)/src -I$(top-srcdir)/tools/lib
+AM_CPPFLAGS=-I$(top_srcdir)/src
+
+# This library is our main target.
+lib_LTLIBRARIES=libhdf5_hl.la
+
+libhdf5_hl_la_SOURCES=H5LT.c H5TB.c H5IM.c H5DS.c
+
+# Public header files (to be installed)
+include_HEADERS=H5IM.h H5LT.h H5TB.h H5DS.h
+
+include $(top_srcdir)/config/conclude.am