summaryrefslogtreecommitdiffstats
path: root/hl/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/src/Makefile.am')
-rw-r--r--hl/src/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/hl/src/Makefile.am b/hl/src/Makefile.am
index 0eecbbb..f3d09ab 100644
--- a/hl/src/Makefile.am
+++ b/hl/src/Makefile.am
@@ -30,8 +30,12 @@ lib_LTLIBRARIES=libhdf5_hl.la
# Add libtool numbers to the HDF5 hl library (from config/lt_vers.am)
libhdf5_hl_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
+# List sources to include in the HDF5 HL Library.
libhdf5_hl_la_SOURCES=H5DS.c H5IM.c H5LT.c H5LTanalyze.c H5LTparse.c H5PT.c H5TB.c
+# HDF5 HL library depends on HDF5 Library.
+libhdf5_hl_la_LIBADD=$(LIBHDF5)
+
# Public header files (to be installed)
include_HEADERS=hdf5_hl.h H5IMpublic.h H5LTpublic.h H5TBpublic.h H5DSpublic.h H5PTpublic.h