summaryrefslogtreecommitdiffstats
path: root/hl/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/test/Makefile.am')
-rw-r--r--hl/test/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/hl/test/Makefile.am b/hl/test/Makefile.am
index 1e8a380..d20b7d3 100644
--- a/hl/test/Makefile.am
+++ b/hl/test/Makefile.am
@@ -32,8 +32,19 @@ LDADD=$(LIBH5_HL) $(LIBH5TEST) $(LIBHDF5)
TEST_PROG=test_lite test_image test_table test_ds test_packet
check_PROGRAMS=$(TEST_PROG)
+# These programs generate test files for the tests. They don't need to be
+# compiled every time we want to test the library. However, putting
+# them in a conditional causes automake to generate rules so that they
+# can be built by hand. They can also be built by specifying
+# --enable-build-all at configure time.
+BUILD_ALL_PROGS=gen_test_ds
+
+if BUILD_ALL_CONDITIONAL
+ noinst_PROGRAMS=$(BUILD_ALL_PROGS)
+endif
+
# Temporary files. These files are the ones created by running `make test'.
-CHECK_CLEANFILES+=combine_tables[1-2].h5 test_ds[1-7].h5 test_image[1-3].h5 \
+CHECK_CLEANFILES+=combine_tables[1-2].h5 test_ds[1-9].h5 test_image[1-3].h5 \
test_lite[1-2].h5 test_table.h5 test_packet_table.h5 \
test_packet_compress.h5