summaryrefslogtreecommitdiffstats
path: root/hl/tools/gif2h5/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hl/tools/gif2h5/Makefile.am')
-rw-r--r--hl/tools/gif2h5/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/hl/tools/gif2h5/Makefile.am b/hl/tools/gif2h5/Makefile.am
index 5318869..e8f6a56 100644
--- a/hl/tools/gif2h5/Makefile.am
+++ b/hl/tools/gif2h5/Makefile.am
@@ -23,12 +23,28 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib -I$(top_srcdir)/hl/src
# These are our main targets, the tools
+
+if BUILD_HDF5_HL_CONDITIONAL
bin_PROGRAMS=gif2h5 h52gif
+else
+bin_PROGRAMS=h52gif
+endif
+if BUILD_HDF5_HL_CONDITIONAL
gif2h5_SOURCES=gif2hdf.c gif2mem.c decompress.c gifread.c writehdf.c
+endif
+
h52gif_SOURCES=hdf2gif.c hdfgifwr.c readhdf.c
+
+
# Programs all depend on the hdf5 library and the tools library
+if BUILD_HDF5_HL_CONDITIONAL
LDADD=$(LIBH5TOOLS) $(LIBH5_HL) $(LIBHDF5)
+else
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+endif
+
+
include $(top_srcdir)/config/conclude.am