summaryrefslogtreecommitdiffstats
path: root/perform/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'perform/CMakeLists.txt')
-rw-r--r--perform/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/perform/CMakeLists.txt b/perform/CMakeLists.txt
index 66a0794..95ffd30 100644
--- a/perform/CMakeLists.txt
+++ b/perform/CMakeLists.txt
@@ -110,12 +110,14 @@ IF (H5_HAVE_PARALLEL)
TARGET_LINK_LIBRARIES (benchpar ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
#-- Adding test for mpi-perf
- SET (mpi-perf_SRCS
- ${HDF5_PERFORM_SOURCE_DIR}/mpi-perf.c
- )
- ADD_EXECUTABLE (mpi-perf ${mpi-perf_SRCS})
- TARGET_NAMING (mpi-perf ${LIB_TYPE})
- TARGET_LINK_LIBRARIES (mpi-perf ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
+ IF (NOT WIN32)
+ SET (mpi-perf_SRCS
+ ${HDF5_PERFORM_SOURCE_DIR}/mpi-perf.c
+ )
+ ADD_EXECUTABLE (mpi-perf ${mpi-perf_SRCS})
+ TARGET_NAMING (mpi-perf ${LIB_TYPE})
+ TARGET_LINK_LIBRARIES (mpi-perf ${HDF5_LIB_TARGET} ${HDF5_TOOLS_LIB_TARGET} ${HDF5_TEST_LIB_TARGET})
+ ENDIF (NOT WIN32)
ENDIF (H5_HAVE_PARALLEL)