summaryrefslogtreecommitdiffstats
path: root/perform/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'perform/Makefile.am')
-rw-r--r--perform/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/perform/Makefile.am b/perform/Makefile.am
index 1dd98b0..c10a80e 100644
--- a/perform/Makefile.am
+++ b/perform/Makefile.am
@@ -30,9 +30,17 @@ endif
# always installed with the tools during make install.
bin_PROGRAMS=h5perf
+# mpi-perf is not built or run by default, but can be built by hand or by
+# specifying --enable-build-all at configure time.
+if BUILD_ALL_CONDITIONAL
+ MPI_PERF=mpi-perf
+else
+ MPI_PERF=
+endif
+
# These are the programs that `make all' or `make tests' will build and which
# `make check' will run. List them in the order they should be run.
-TEST_PROG = iopipe chunk overhead zip_perf perf_meta
+TEST_PROG = iopipe chunk overhead zip_perf perf_meta $(MPI_PERF)
check_PROGRAMS=$(TEST_PROG_PARA) $(TEST_PROG) perf
h5perf_SOURCES=pio_perf.c pio_engine.c pio_timer.c