summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am28
1 files changed, 27 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index edfd9b0..0dbb175 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -118,6 +118,16 @@ if BUILD_PARALLEL_CONDITIONAL
libhdf5_la_SOURCES += H5mpi.c H5ACmpio.c H5Cmpio.c H5Dmpio.c H5Fmpi.c H5FDmpi.c H5FDmpio.c H5Smpio.c
endif
+# Only compile the subfiling VFD if necessary
+if SUBFILING_VFD_CONDITIONAL
+ libhdf5_la_SOURCES += H5FDsubfiling/H5FDsubfiling.c \
+ H5FDsubfiling/H5FDsubfile_int.c \
+ H5FDsubfiling/H5FDioc.c \
+ H5FDsubfiling/H5FDioc_int.c \
+ H5FDsubfiling/H5FDioc_threads.c \
+ H5FDsubfiling/H5subfiling_common.c
+endif
+
# Only compile the direct VFD if necessary
if DIRECT_VFD_CONDITIONAL
libhdf5_la_SOURCES += H5FDdirect.c
@@ -145,7 +155,8 @@ include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5vers
H5Epubgen.h H5Epublic.h H5ESpublic.h H5Fpublic.h \
H5FDpublic.h H5FDcore.h H5FDdirect.h H5FDfamily.h H5FDhdfs.h \
H5FDlog.h H5FDmirror.h H5FDmpi.h H5FDmpio.h H5FDmulti.h H5FDros3.h \
- H5FDsec2.h H5FDsplitter.h H5FDstdio.h H5FDwindows.h \
+ H5FDsec2.h H5FDsplitter.h \
+ H5FDstdio.h H5FDwindows.h H5FDsubfiling/H5FDsubfiling.h H5FDsubfiling/H5FDioc.h \
H5Gpublic.h H5Ipublic.h H5Lpublic.h \
H5Mpublic.h H5MMpublic.h H5Opublic.h H5Ppublic.h \
H5PLextern.h H5PLpublic.h \
@@ -158,6 +169,21 @@ include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5vers
include_HEADERS += H5ESdevelop.h H5FDdevelop.h H5Idevelop.h H5Ldevelop.h \
H5Tdevelop.h H5TSdevelop.h H5Zdevelop.h
+if SUBFILING_VFD_CONDITIONAL
+
+# Temporarily use internal Mercury until usage of Mercury is refactored
+if HAVE_MERCURY_CONDITIONAL
+ include_HEADERS += H5FDsubfiling/mercury/src/util/mercury_thread.h \
+ H5FDsubfiling/mercury/src/util/mercury_thread_mutex.h H5FDsubfiling/mercury/src/util/mercury_thread_pool.h
+
+ libhdf5_la_SOURCES += H5FDsubfiling/mercury/src/util/mercury_dlog.c \
+ H5FDsubfiling/mercury/src/util/mercury_log.c H5FDsubfiling/mercury/src/util/mercury_thread.c \
+ H5FDsubfiling/mercury/src/util/mercury_thread_condition.c H5FDsubfiling/mercury/src/util/mercury_thread_pool.c \
+ H5FDsubfiling/mercury/src/util/mercury_thread_mutex.c H5FDsubfiling/mercury/src/util/mercury_util.c
+endif
+
+endif
+
# install libhdf5.settings in lib directory
settingsdir=$(libdir)
settings_DATA=libhdf5.settings