summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 1 insertions, 16 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 73a8c83..0eaae1a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -32,18 +32,10 @@ lib_LTLIBRARIES=libhdf5.la
# Add libtool numbers to the HDF5 library (from config/lt_vers.am)
libhdf5_la_LDFLAGS= -version-info $(LT_VERS_INTERFACE):$(LT_VERS_REVISION):$(LT_VERS_AGE) $(AM_LDFLAGS)
-# h5cc needs custom install and uninstall rules, since it may be
-# named h5pcc if hdf5 is being built in parallel mode.
-if BUILD_PARALLEL_CONDITIONAL
- H5CC_NAME=h5pcc
-else
- H5CC_NAME=h5cc
-endif
-
# H5Tinit.c and H5lib_settings.c are generated files and should be cleaned.
MOSTLYCLEANFILES=H5Tinit.c H5lib_settings.c
# H5pubconf.h is generated by configure, and should be cleaned.
-DISTCLEANFILES=H5pubconf.h $(H5CC_NAME)
+DISTCLEANFILES=H5pubconf.h
# library sources
libhdf5_la_SOURCES= H5.c H5checksum.c H5dbg.c H5system.c H5timer.c H5trace.c \
@@ -160,8 +152,6 @@ include_HEADERS = hdf5.h H5api_adpt.h H5overflow.h H5pubconf.h H5public.h H5vers
settingsdir=$(libdir)
settings_DATA=libhdf5.settings
-bin_SCRIPTS=$(H5CC_NAME)
-
# Number format detection
# The LD_LIBRARY_PATH setting is a kludge.
# Things should have been all set during H5detect making.
@@ -220,10 +210,5 @@ trace: $(libhdf5_la_SOURCES)
fi; \
done
-#install-exec-local:
-# @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
-#uninstall-local:
-# @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
-
include $(top_srcdir)/config/conclude.am