summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 62b309d..61f1ed5 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -78,12 +78,16 @@ endif
if HAVE_SHARED_CONDITIONAL
# The libh5test library provides common support code for the tests.
- noinst_LTLIBRARIES=libh5test.la libdynlib1.la
+ noinst_LTLIBRARIES=libh5test.la
# The libdynlib1 library for testing plugin module plugin.c.
# Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlib1.la
libdynlib1_la_SOURCES=dynlib1.c
- libdynlib1_la_LDFLAGS=-rpath /tmp
+
+install-data-local:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib1*
+
else
# The libh5test library provides common support code for the tests.
noinst_LTLIBRARIES=libh5test.la