summaryrefslogtreecommitdiffstats
path: root/testpar/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'testpar/CMakeLists.txt')
-rw-r--r--testpar/CMakeLists.txt24
1 files changed, 4 insertions, 20 deletions
diff --git a/testpar/CMakeLists.txt b/testpar/CMakeLists.txt
index d34b800..6bb5fa6 100644
--- a/testpar/CMakeLists.txt
+++ b/testpar/CMakeLists.txt
@@ -104,30 +104,14 @@ set (H5P_TESTS
t_vfd
)
-set (HDF5_API_TESTS
- attribute
- dataset
- datatype
- file
- group
- link
- misc
- object
-)
-
-if (HDF5_TEST_API_ENABLE_ASYNC)
- set (HDF5_API_TESTS
- ${HDF5_API_TESTS}
- async
- )
-endif ()
-
foreach (h5_testp ${H5P_TESTS})
ADD_H5P_EXE(${h5_testp})
endforeach ()
-add_subdirectory (API)
-
if (HDF5_TEST_PARALLEL)
include (CMakeTests.cmake)
endif ()
+
+if (HDF5_TEST_API)
+ add_subdirectory (API)
+endif ()