summaryrefslogtreecommitdiffstats
path: root/testpar/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'testpar/Makefile.am')
-rw-r--r--testpar/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/testpar/Makefile.am b/testpar/Makefile.am
index ff4a3dd..b53553a 100644
--- a/testpar/Makefile.am
+++ b/testpar/Makefile.am
@@ -21,6 +21,10 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test
+if SUBFILING_VFD_CONDITIONAL
+ AM_CPPFLAGS += -I$(top_srcdir)/src/H5FDsubfiling
+endif
+
# Test scripts--
# testpflush.sh:
TEST_SCRIPT_PARA = testpflush.sh
@@ -32,6 +36,10 @@ check_SCRIPTS = $(TEST_SCRIPT_PARA)
#
TEST_PROG_PARA=t_mpi t_bigio testphdf5 t_cache t_cache_image t_pread t_pshutdown t_prestart t_init_term t_shapesame t_filters_parallel t_2Gio t_vfd
+if SUBFILING_VFD_CONDITIONAL
+ TEST_PROG_PARA += t_subfiling_vfd
+endif
+
# t_pflush1 and t_pflush2 are used by testpflush.sh
check_PROGRAMS = $(TEST_PROG_PARA) t_pflush1 t_pflush2