summaryrefslogtreecommitdiffstats
path: root/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/CMakeLists.txt')
-rw-r--r--tools/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/tools/CMakeLists.txt b/tools/CMakeLists.txt
index 4b3b3d5..5576f5c 100644
--- a/tools/CMakeLists.txt
+++ b/tools/CMakeLists.txt
@@ -1,4 +1,4 @@
-cmake_minimum_required (VERSION 3.2.2)
+cmake_minimum_required (VERSION 3.10)
PROJECT (HDF5_TOOLS)
#-----------------------------------------------------------------------------
@@ -9,9 +9,7 @@ add_definitions (${HDF_EXTRA_C_FLAGS})
# --------------------------------------------------------------------
# If testing was NOT enabled, then we need to build the tools library
# --------------------------------------------------------------------
-if (NOT BUILD_TESTING)
- add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/lib)
-endif ()
+add_subdirectory (lib)
#-----------------------------------------------------------------------------
# Setup include Directories
@@ -19,9 +17,9 @@ endif ()
INCLUDE_DIRECTORIES (${HDF5_TOOLS_SOURCE_DIR}/lib)
#-- Add the test sources
-add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/src)
+add_subdirectory (src)
#-- Add the tests
if (BUILD_TESTING)
- add_subdirectory (${HDF5_TOOLS_SOURCE_DIR}/test)
+ add_subdirectory (test)
endif ()