summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index b0c33ed..4a59121 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -19,9 +19,15 @@
include $(top_srcdir)/config/commence.am
+if BUILD_TESTS_CONDITIONAL
+ TESTSERIAL_DIR =test
+else
+ TESTSERIAL_DIR=
+endif
+
CONFIG=ordered
# All subdirectories
-SUBDIRS=lib src test
+SUBDIRS=lib src $(TESTSERIAL_DIR)
include $(top_srcdir)/config/conclude.am