summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5copy/Makefile.am')
-rw-r--r--tools/h5copy/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/h5copy/Makefile.am b/tools/h5copy/Makefile.am
index 8d1f0ac..693f3f1 100644
--- a/tools/h5copy/Makefile.am
+++ b/tools/h5copy/Makefile.am
@@ -22,8 +22,13 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_PROG=h5copygentest
-TEST_SCRIPT=testh5copy.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5copygentest
+ TEST_SCRIPT=testh5copy.sh
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=h5copy$(EXEEXT)