summaryrefslogtreecommitdiffstats
path: root/tools/h5copy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5copy/Makefile.am')
-rw-r--r--tools/h5copy/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/tools/h5copy/Makefile.am b/tools/h5copy/Makefile.am
index 9632c1b..17f650c 100644
--- a/tools/h5copy/Makefile.am
+++ b/tools/h5copy/Makefile.am
@@ -23,12 +23,17 @@ include $(top_srcdir)/config/commence.am
INCLUDES=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
+TEST_PROG=h5copygentest
TEST_SCRIPT=$(srcdir)/testh5copy.sh
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=h5copy$(EXEEXT)
# This is our main target, the h5copy tool
bin_PROGRAMS=h5copy
+check_PROGRAMS=$(TEST_PROG)
+
+# source file for the test file generator
+h5copygentest_SOURCES=h5copygentest.c
# All programs depend on the hdf5 and h5tools libraries
LDADD=$(LIBH5TOOLS) $(LIBHDF5)