summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am9
1 files changed, 3 insertions, 6 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index afbcd05..68710a1 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -33,8 +33,7 @@ else
endif
# Our main target, h5diff
-bin_PROGRAMS=h5diff
-bin_SCRIPTS=$(H5PDIFF)
+bin_PROGRAMS=h5diff $(H5PDIFF)
# Test programs and scripts
TEST_PROG=h5difftst
@@ -44,7 +43,8 @@ check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT)
# Source files for the program
-h5diff_SOURCES=h5diff_main.c
+h5diff_SOURCES=h5diff_main.c h5diff_common.c
+ph5diff_SOURCES=ph5diff_main.c h5diff_common.c
h5difftst_SOURCES=testh5diff_main.c testh5diff_attr.c \
testh5diff_basic.c testh5diff_dset.c testh5diff_util.c
@@ -55,8 +55,5 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
# be copied to the testfiles/ directory if update is required
MOSTLYCLEANFILES=*.h5
-ph5diff: h5diff
- @$(CP) $? $@
-
include $(top_srcdir)/config/conclude.am