summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
new file mode 100644
index 0000000..ea4fa49
--- /dev/null
+++ b/tools/h5diff/Makefile.am
@@ -0,0 +1,48 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src and tools/lib directories
+AM_CFLAGS=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+# Our main target, h5diff
+bin_PROGRAMS=h5diff
+
+# Test programs and scripts
+TEST_PROG=h5difftst
+TEST_SCRIPT=$(srcdir)/testh5diff.sh
+
+check_PROGRAMS=$(TEST_PROG)
+check_SCRIPTS=$(TEST_SCRIPT)
+
+# Source files for the program
+h5diff_SOURCES=h5diff_main.c
+h5difftst_SOURCES=testh5diff_main.c testh5diff_attr.c \
+ testh5diff_basic.c testh5diff_dset.c testh5diff_util.c
+
+# Programs depend on the main HDF5 library and tools library
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+# Temporary files. *.h5 are generated by h5diff. They should
+# be copied to the testfiles/ directory if update is required
+MOSTLYCLEANFILES=*.h5
+
+include $(top_srcdir)/config/conclude.am
+