summaryrefslogtreecommitdiffstats
path: root/tools/h5diff/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5diff/Makefile.am')
-rw-r--r--tools/h5diff/Makefile.am20
1 files changed, 10 insertions, 10 deletions
diff --git a/tools/h5diff/Makefile.am b/tools/h5diff/Makefile.am
index 44349e9..ce3a370 100644
--- a/tools/h5diff/Makefile.am
+++ b/tools/h5diff/Makefile.am
@@ -36,27 +36,27 @@ h5diff_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)
# Test programs and scripts
if BUILD_TESTS_CONDITIONAL
- TEST_PROG=h5diffgentest
- TEST_SCRIPT=testh5diff.sh
+TEST_PROG=h5diffgentest
+TEST_SCRIPT=testh5diff.sh
+ h5diffgentest_SOURCES=h5diffgentest.c
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5diff_plugin.sh
+endif
+endif
else
- TEST_PROG=
- TEST_SCRIPT=
+TEST_PROG=
+TEST_SCRIPT=
endif
check_PROGRAMS=$(TEST_PROG)
check_SCRIPTS=$(TEST_SCRIPT) $(TEST_SCRIPT_PARA)
# The parallel test script testph5diff.sh actually depends on testh5diff.sh.
SCRIPT_DEPEND=h5diff$(EXEEXT) $(H5PDIFF) testh5diff.sh
-if HAVE_SHARED_CONDITIONAL
-if USE_PLUGINS_CONDITIONAL
- TEST_SCRIPT += h5diff_plugin.sh
-endif
-endif
# Source files for the program
h5diff_SOURCES=h5diff_main.c h5diff_common.c
ph5diff_SOURCES=ph5diff_main.c h5diff_common.c
-h5diffgentest_SOURCES=h5diffgentest.c
# Programs depend on the main HDF5 library and tools library
LDADD=$(LIBH5TOOLS) $(LIBHDF5)