summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5dump/Makefile.am')
-rw-r--r--tools/h5dump/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tools/h5dump/Makefile.am b/tools/h5dump/Makefile.am
index cee4801..6d95bb2 100644
--- a/tools/h5dump/Makefile.am
+++ b/tools/h5dump/Makefile.am
@@ -30,6 +30,11 @@ TEST_SCRIPT=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh
check_PROGRAMS=$(TEST_PROG) binread
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=h5dump$(EXEEXT)
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5dump_plugin.sh
+endif
+endif
# Our main target, the h5dump tool.
bin_PROGRAMS=h5dump
@@ -43,6 +48,15 @@ LDADD=$(LIBH5TOOLS) $(LIBHDF5)
# Source files for the program
h5dump_SOURCES=h5dump.c h5dump_ddl.c h5dump_xml.c
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibdump.la
+ libdynlibdump_la_SOURCES=dynlib_dump.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
# Temporary files. *.h5 are generated by h5dumpgentest. They should
# copied to the testfiles/ directory if update is required.
CHECK_CLEANFILES+=*.h5 *.bin