summaryrefslogtreecommitdiffstats
path: root/tools/h5dump/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5dump/Makefile.am')
-rw-r--r--tools/h5dump/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/h5dump/Makefile.am b/tools/h5dump/Makefile.am
index ff1c497..1766bc6 100644
--- a/tools/h5dump/Makefile.am
+++ b/tools/h5dump/Makefile.am
@@ -22,8 +22,13 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_PROG=h5dumpgentest
-TEST_SCRIPT=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5dumpgentest
+ TEST_SCRIPT=testh5dump.sh testh5dumppbits.sh testh5dumpxml.sh
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_PROGRAMS=$(TEST_PROG) binread
check_SCRIPTS=$(TEST_SCRIPT)