summaryrefslogtreecommitdiffstats
path: root/tools/h5import/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5import/Makefile.am')
-rw-r--r--tools/h5import/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/h5import/Makefile.am b/tools/h5import/Makefile.am
index 3f75bdc..ed5eb2c 100644
--- a/tools/h5import/Makefile.am
+++ b/tools/h5import/Makefile.am
@@ -22,8 +22,13 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_PROG=h5importtest
-TEST_SCRIPT=h5importtestutil.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5importtest
+ TEST_SCRIPT=h5importtestutil.sh
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_PROGRAMS=$(TEST_PROG)
check_SCRIPT=h5importtestutil.sh