summaryrefslogtreecommitdiffstats
path: root/tools/h5jam/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5jam/Makefile.am')
-rw-r--r--tools/h5jam/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tools/h5jam/Makefile.am b/tools/h5jam/Makefile.am
index fbc8f6a..c1118e1 100644
--- a/tools/h5jam/Makefile.am
+++ b/tools/h5jam/Makefile.am
@@ -23,7 +23,12 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
bin_PROGRAMS=h5jam h5unjam
check_PROGRAMS=tellub h5jamgentest getub
-TEST_SCRIPT=testh5jam.sh
+
+if BUILD_TESTS_CONDITIONAL
+ TEST_SCRIPT=testh5jam.sh
+else
+ TEST_SCRIPT=
+endif
# Add h5jam and h5unjam specific linker flags here
h5jam_LDFLAGS = $(LT_STATIC_EXEC) $(AM_LDFLAGS)