summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt40
1 files changed, 38 insertions, 2 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index c81f42b..431a693 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -11,8 +11,7 @@ INCLUDE_DIRECTORIES (${HDF5_PROJECT_DIR}/test)
# Add the h5ls executable
#-----------------------------------------------------------------------------
ADD_EXECUTABLE (h5ls ${HDF5_TOOLS_H5LS_SOURCE_DIR}/h5ls.c)
-H5_NAMING (h5ls)
-TARGET_WIN_PROPERTIES (h5ls)
+H5_NAMING (h5ls ${LIB_TYPE})
TARGET_LINK_LIBRARIES (h5ls ${HDF5_TOOLS_LIB_TARGET} ${HDF5_LIB_TARGET})
SET (H5_DEP_EXECUTABLES
@@ -63,6 +62,7 @@ IF (BUILD_TESTING)
tsoftlinks-5.ls
textlinksrc-nodangle-1.ls
textlinksrc-nodangle-2.ls
+ tgrp_comments.ls
tsoftlinks-nodangle-1.ls
thlinks-nodangle-1.ls
tgroup.ls
@@ -72,6 +72,9 @@ IF (BUILD_TESTING)
thlink-1.ls
tloop-1.ls
tnestcomp-1.ls
+ tnestcomp-2.ls
+ tnestcomp-3.ls
+ tnestcomp-4.ls
tsaf.ls
tslink-1.ls
tstr-1.ls
@@ -92,6 +95,7 @@ IF (BUILD_TESTING)
textlinksrc.h5
textlinktar.h5
tgroup.h5
+ tgrp_comments.h5
thlink.h5
tloop.h5
tnestedcomp.h5
@@ -143,6 +147,10 @@ IF (BUILD_TESTING)
-D "TEST_REFERENCE=${resultfile}.ls"
-P "${HDF5_RESOURCES_DIR}/runTest.cmake"
)
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (H5LS-${resultfile} PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "H5LS-${resultfile}")
ENDMACRO (ADD_H5_TEST file)
##############################################################################
@@ -208,6 +216,8 @@ IF (BUILD_TESTING)
textlinksrc-6-old.out.err
textlinksrc-7-old.out
textlinksrc-7-old.out.err
+ tgrp_comments.out
+ tgrp_comments.out.err
tsoftlinks-1.out
tsoftlinks-1.out.err
tsoftlinks-2.out
@@ -240,6 +250,12 @@ IF (BUILD_TESTING)
tloop-1.out.err
tnestcomp-1.out
tnestcomp-1.out.err
+ tnestcomp-2.out
+ tnestcomp-2.out.err
+ tnestcomp-3.out
+ tnestcomp-3.out.err
+ tnestcomp-4.out
+ tnestcomp-4.out.err
tsaf.out
tsaf.out.err
tslink-1.out
@@ -255,6 +271,17 @@ IF (BUILD_TESTING)
tvldtypes2be.out
tvldtypes2be.out.err
)
+ IF (NOT "${last_test}" STREQUAL "")
+ SET_TESTS_PROPERTIES (H5LS-clearall-objects PROPERTIES DEPENDS ${last_test})
+ ENDIF (NOT "${last_test}" STREQUAL "")
+ SET (last_test "H5LS-clearall-objects")
+
+ # If using memchecker add tests without using scripts
+ IF (HDF5_ENABLE_USING_MEMCHECKER)
+ ADD_TEST (NAME H5LS-help COMMAND h5ls -w80 -h)
+ ADD_TEST (NAME H5LS-tall COMMAND h5ls -w80 tall.h5)
+ ADD_TEST (NAME H5LS-tsoftlinks COMMAND h5ls --follow-symlinks tsoftlinks.h5)
+ ENDIF (HDF5_ENABLE_USING_MEMCHECKER)
# test the help syntax
ADD_H5_TEST (help-1 0 -w80 -h)
@@ -273,6 +300,9 @@ IF (BUILD_TESTING)
ADD_H5_TEST (tgroup-1 1 -w80 -r -g tgroup.h5)
ADD_H5_TEST (tgroup-2 0 -w80 -g tgroup.h5/g1)
+ # test for files with groups that have long comments
+ ADD_H5_TEST (tgrp_comments 0 -w80 -v -g tgrp_comments.h5/glongcomment)
+
# test for displaying simple space datasets
ADD_H5_TEST (tdset-1 0 -w80 -r -d tdset.h5)
@@ -325,6 +355,12 @@ IF (BUILD_TESTING)
#test for the nested compound type
ADD_H5_TEST (tnestcomp-1 0 -w80 -r -d tnestedcomp.h5)
+ ADD_H5_TEST (tnestcomp-2 0 -w80 -r -d -S tnestedcomp.h5)
+
+ ADD_H5_TEST (tnestcomp-3 0 -w80 -r -d -l tnestedcomp.h5)
+
+ ADD_H5_TEST (tnestcomp-4 0 -w80 -r -d -l -S tnestedcomp.h5)
+
# test for loop detection
ADD_H5_TEST (tloop-1 0 -w80 -r -d tloop.h5)