summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5ls/CMakeLists.txt')
-rw-r--r--tools/h5ls/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/h5ls/CMakeLists.txt b/tools/h5ls/CMakeLists.txt
index c81f42b..149e69f 100644
--- a/tools/h5ls/CMakeLists.txt
+++ b/tools/h5ls/CMakeLists.txt
@@ -72,6 +72,9 @@ IF (BUILD_TESTING)
thlink-1.ls
tloop-1.ls
tnestcomp-1.ls
+ tnestcomp-2.ls
+ tnestcomp-3.ls
+ tnestcomp-4.ls
tsaf.ls
tslink-1.ls
tstr-1.ls
@@ -240,6 +243,12 @@ IF (BUILD_TESTING)
tloop-1.out.err
tnestcomp-1.out
tnestcomp-1.out.err
+ tnestcomp-2.out
+ tnestcomp-2.out.err
+ tnestcomp-3.out
+ tnestcomp-3.out.err
+ tnestcomp-4.out
+ tnestcomp-4.out.err
tsaf.out
tsaf.out.err
tslink-1.out
@@ -325,6 +334,12 @@ IF (BUILD_TESTING)
#test for the nested compound type
ADD_H5_TEST (tnestcomp-1 0 -w80 -r -d tnestedcomp.h5)
+ ADD_H5_TEST (tnestcomp-2 0 -w80 -r -d -S tnestedcomp.h5)
+
+ ADD_H5_TEST (tnestcomp-3 0 -w80 -r -d -l tnestedcomp.h5)
+
+ ADD_H5_TEST (tnestcomp-4 0 -w80 -r -d -l -S tnestedcomp.h5)
+
# test for loop detection
ADD_H5_TEST (tloop-1 0 -w80 -r -d tloop.h5)