summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5ls/Makefile.am')
-rw-r--r--tools/h5ls/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/tools/h5ls/Makefile.am b/tools/h5ls/Makefile.am
index ee31ca2..2724b34 100644
--- a/tools/h5ls/Makefile.am
+++ b/tools/h5ls/Makefile.am
@@ -23,17 +23,17 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
if BUILD_TESTS_CONDITIONAL
- TEST_SCRIPT=testh5ls.sh
-else
- TEST_SCRIPT=
-endif
-check_SCRIPTS=$(TEST_SCRIPT)
-SCRIPT_DEPEND=h5ls$(EXEEXT)
+TEST_SCRIPT=testh5ls.sh
if HAVE_SHARED_CONDITIONAL
if USE_PLUGINS_CONDITIONAL
TEST_SCRIPT += h5ls_plugin.sh
endif
endif
+else
+TEST_SCRIPT=
+endif
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=h5ls$(EXEEXT)
# This is our main target, the h5ls tool
bin_PROGRAMS=h5ls