summaryrefslogtreecommitdiffstats
path: root/tools/h5ls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5ls/Makefile.am')
-rw-r--r--tools/h5ls/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tools/h5ls/Makefile.am b/tools/h5ls/Makefile.am
index 1109e82..ee31ca2 100644
--- a/tools/h5ls/Makefile.am
+++ b/tools/h5ls/Makefile.am
@@ -22,7 +22,11 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
# Test programs and scripts
-TEST_SCRIPT=testh5ls.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_SCRIPT=testh5ls.sh
+else
+ TEST_SCRIPT=
+endif
check_SCRIPTS=$(TEST_SCRIPT)
SCRIPT_DEPEND=h5ls$(EXEEXT)
if HAVE_SHARED_CONDITIONAL