summaryrefslogtreecommitdiffstats
path: root/tools/h5repack/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/h5repack/Makefile.am')
-rw-r--r--tools/h5repack/Makefile.am21
1 files changed, 10 insertions, 11 deletions
diff --git a/tools/h5repack/Makefile.am b/tools/h5repack/Makefile.am
index 01eb703..86dc51b 100644
--- a/tools/h5repack/Makefile.am
+++ b/tools/h5repack/Makefile.am
@@ -23,20 +23,21 @@ AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib
# Test programs and scripts
if BUILD_TESTS_CONDITIONAL
- TEST_SCRIPT=h5repack.sh
- TEST_PROG=h5repacktst
-else
- TEST_SCRIPT=
- TEST_PROG=
-endif
-noinst_PROGRAMS=testh5repack_detect_szip
-
-SCRIPT_DEPEND=h5repack$(EXEEXT)
+TEST_SCRIPT=h5repack.sh
+TEST_PROG=h5repacktst
+ h5repacktst_SOURCES=$(COMMON_SOURCES) h5repacktst.c
if HAVE_SHARED_CONDITIONAL
if USE_PLUGINS_CONDITIONAL
TEST_SCRIPT += h5repack_plugin.sh
endif
endif
+else
+TEST_SCRIPT=
+TEST_PROG=
+endif
+noinst_PROGRAMS=testh5repack_detect_szip
+
+SCRIPT_DEPEND=h5repack$(EXEEXT)
check_SCRIPTS=$(TEST_SCRIPT)
check_PROGRAMS=$(TEST_PROG)
@@ -57,8 +58,6 @@ COMMON_SOURCES=h5repack.c h5repack_copy.c h5repack_filters.c \
h5repack_SOURCES=$(COMMON_SOURCES) h5repack_main.c
-h5repacktst_SOURCES=$(COMMON_SOURCES) h5repacktst.c
-
testh5repack_detect_szip_SOURCES=testh5repack_detect_szip.c
# The h5repack.sh script needs h5repacktst to run first.