summaryrefslogtreecommitdiffstats
path: root/tools/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/lib/Makefile.am')
-rw-r--r--tools/lib/Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/tools/lib/Makefile.am b/tools/lib/Makefile.am
index 4257e6a..dad3db3 100644
--- a/tools/lib/Makefile.am
+++ b/tools/lib/Makefile.am
@@ -22,18 +22,13 @@ include $(top_srcdir)/config/commence.am
# Include files in /src directory
INCLUDES=-I$(top_srcdir)/src
-# This is our main target, the h5tools library. We link this library
-# statically because some systems can only link executables to a single
-# shared library and libhdf5 is much bigger than libh5tools.
+# This is our main target, the h5tools library.
noinst_LTLIBRARIES=libh5tools.la
-libh5tools_la_LDFLAGS=-static
+
libh5tools_la_SOURCES=h5tools.c h5tools_str.c h5tools_utils.c h5diff.c \
h5diff_array.c h5diff_attr.c h5diff_dset.c h5diff_util.c h5trav.c \
h5trav_table.c h5tools_filters.c h5tools_ref.c h5tools_type.c
-# Link the h5tools library using the main hdf5 library
-LIBADD=$(LIBHDF5)
-
# Test program. Link using libhdf5 and libh5tools
TEST_PROG=talign
check_PROGRAMS=$(TEST_PROG)