summaryrefslogtreecommitdiffstats
path: root/tools/libtest/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/libtest/CMakeLists.txt')
-rw-r--r--tools/libtest/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tools/libtest/CMakeLists.txt b/tools/libtest/CMakeLists.txt
index 3e0f671..d094058 100644
--- a/tools/libtest/CMakeLists.txt
+++ b/tools/libtest/CMakeLists.txt
@@ -16,6 +16,13 @@ else ()
endif ()
set_target_properties (h5tools_test_utils PROPERTIES FOLDER tools)
+#-----------------------------------------------------------------------------
+# Add Target to clang-format
+#-----------------------------------------------------------------------------
+if (HDF5_ENABLE_FORMATTERS)
+ clang_format (HDF5_H5TOOLS_TEST_SRC_FORMAT h5tools_test_utils)
+endif ()
+
if (HDF5_TEST_TOOLS AND HDF5_TEST_SERIAL)
include (CMakeTests.cmake)
endif ()