summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am18
1 files changed, 15 insertions, 3 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
index 914650c..fd1a866 100644
--- a/tools/misc/Makefile.am
+++ b/tools/misc/Makefile.am
@@ -22,20 +22,32 @@ include $(top_srcdir)/config/commence.am
# Include src directory
INCLUDES=-I$(top_srcdir)/src
+#test script and program
+TEST_PROG=h5repart_gentest
+TEST_SCRIPT=testh5repart.sh
+
+check_PROGRAMS=$(TEST_PROG)
+check_SCRIPTS=$(TEST_SCRIPT)
+
# Build pdb2hdf5 if LLNL's PDB is present (checked in configure)
if BUILD_PDB2HDF_CONDITIONAL
PDB2HDF=pdb2hdf5
endif
# These are our main targets, the tools
-bin_PROGRAMS=h5debug h5repart $(PDB2HDF)
+bin_PROGRAMS=h5debug h5repart $(PDB2HDF) repart_test
bin_SCRIPTS=h5redeploy
# Tell automake to clean h5redeploy script
CLEANFILES=h5redeploy
-# h5cc is generated by configure. Remove it only when distclean.
-DISTCLEANFILES=h5cc
+# Temporary files. *.h5 are generated by h5repart_gentest. They should
+# copied to the testfiles/ directory if update is required. fst_family*.h5
+# and scd_family*.h5 were created by setting the HDF5_NOCLEANUP variable.
+MOSTLYCLEANFILES=*.h5 ../testfiles/fst_family*.h5 ../testfiles/scd_family*.h5
+
+# These were generated by configure. Remove them only when distclean.
+DISTCLEANFILES=h5cc testh5repart.sh
# All programs rely on hdf5 library and h5tools library
LDADD=$(LIBHDF5) $(LIBH5TOOLS)