summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
index 91a045e..d522f64 100644
--- a/tools/misc/Makefile.am
+++ b/tools/misc/Makefile.am
@@ -22,8 +22,13 @@ include $(top_srcdir)/config/commence.am
AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
#test script and program
-TEST_PROG=h5repart_gentest talign
-TEST_SCRIPT=testh5repart.sh testh5mkgrp.sh
+if BUILD_TESTS_CONDITIONAL
+ TEST_PROG=h5repart_gentest talign
+ TEST_SCRIPT=testh5repart.sh testh5mkgrp.sh
+else
+ TEST_PROG=
+ TEST_SCRIPT=
+endif
check_PROGRAMS=$(TEST_PROG) repart_test
check_SCRIPTS=$(TEST_SCRIPT)