summaryrefslogtreecommitdiffstats
path: root/tools/misc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/misc/Makefile.am')
-rw-r--r--tools/misc/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/tools/misc/Makefile.am b/tools/misc/Makefile.am
new file mode 100644
index 0000000..52ee9df
--- /dev/null
+++ b/tools/misc/Makefile.am
@@ -0,0 +1,60 @@
+#
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdf.ncsa.uiuc.edu/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from hdfhelp@ncsa.uiuc.edu.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src directory
+AM_CFLAGS=-I$(top_srcdir)/src
+
+# Build pdb2hdf5 if LLNL's PDB is present (checked in configure)
+if BUILD_PDB2HDF_CONDITIONAL
+ PDB2HDF=pdb2hdf5
+endif
+
+# These are our main targets, the tools
+bin_PROGRAMS=h5debug h5repart $(PDB2HDF)
+bin_SCRIPTS=h5redeploy
+
+# Tell automake to clean h5redeploy script
+CLEANFILES=h5redeploy
+
+# h5cc is generated by configure. Remove it only when distclean.
+DISTCLEANFILES=h5cc
+
+# All programs rely on hdf5 library and h5tools library
+LDADD=$(LIBHDF5) $(LIBH5TOOLS)
+
+# h5cc needs custom install and uninstall rules, since it may be
+# named h5pcc if hdf5 is being built in parallel mode.
+if BUILD_PARALLEL_CONDITIONAL
+ H5CC_NAME=h5pcc
+else
+ H5CC_NAME=h5cc
+endif
+
+install-exec-local:
+ $(INSTALL) h5cc $(bindir)/$(H5CC_NAME)
+uninstall-local:
+ $(RM) $(bindir)/$(H5CC_NAME)
+
+# How to build h5redeploy script
+h5redeploy: h5redeploy.in
+ cp $(srcdir)/$@.in $@
+
+include $(top_srcdir)/config/conclude.am