summaryrefslogtreecommitdiffstats
path: root/tools/test/h5jam/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/test/h5jam/Makefile.am')
-rw-r--r--tools/test/h5jam/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/tools/test/h5jam/Makefile.am b/tools/test/h5jam/Makefile.am
new file mode 100644
index 0000000..068f437
--- /dev/null
+++ b/tools/test/h5jam/Makefile.am
@@ -0,0 +1,40 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src and tools/lib directories
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/tools/lib
+
+check_PROGRAMS=tellub h5jamgentest getub
+TEST_SCRIPT=testh5jam.sh
+
+check_SCRIPTS=$(TEST_SCRIPT)
+SCRIPT_DEPEND=../../src/h5jam/h5jam$(EXEEXT) ../../src/h5jam/h5unjam$(EXEEXT)
+
+# Link against the main HDF5 library and tools library
+LDADD=$(LIBH5TOOLS) $(LIBHDF5)
+
+# Temporary files. *.h5 are generated by jamgentest. They should
+# copied to the testfiles/ directory if update is required.
+CHECK_CLEANFILES+=*.h5 testfiles/h5jam-*-sav testfiles/h5unjam-*-sav
+DISTCLEANFILES=testh5jam.sh
+
+include $(top_srcdir)/config/conclude.am