summaryrefslogtreecommitdiffstats
path: root/tools/test/h5repack/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/test/h5repack/Makefile.am')
-rw-r--r--tools/test/h5repack/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/tools/test/h5repack/Makefile.am b/tools/test/h5repack/Makefile.am
new file mode 100644
index 0000000..6c045c4
--- /dev/null
+++ b/tools/test/h5repack/Makefile.am
@@ -0,0 +1,67 @@
+#
+# Copyright by The HDF Group.
+# Copyright by the Board of Trustees of the University of Illinois.
+# All rights reserved.
+#
+# This file is part of HDF5. The full HDF5 copyright notice, including
+# terms governing use, modification, and redistribution, is contained in
+# the files COPYING and Copyright.html. COPYING can be found at the root
+# of the source code distribution tree; Copyright.html can be found at the
+# root level of an installed copy of the electronic HDF5 document set and
+# is linked from the top-level documents page. It can also be found at
+# http://hdfgroup.org/HDF5/doc/Copyright.html. If you do not have
+# access to either file, you may request a copy from help@hdfgroup.org.
+##
+## Makefile.am
+## Run automake to generate a Makefile.in from this file.
+#
+# HDF5 Library Makefile(.in)
+#
+
+include $(top_srcdir)/config/commence.am
+
+# Include src, test, and tools/lib directories
+AM_CPPFLAGS+=-I$(top_srcdir)/src -I$(top_srcdir)/test -I$(top_srcdir)/tools/lib -I$(top_srcdir)/tools/src/h5repack
+
+# Test programs and scripts
+TEST_SCRIPT=h5repack.sh
+
+noinst_PROGRAMS=h5repacktst testh5repack_detect_szip
+
+SCRIPT_DEPEND=../../src/h5repack/h5repack$(EXEEXT) h5repacktst$(EXEEXT)
+if HAVE_SHARED_CONDITIONAL
+if USE_PLUGINS_CONDITIONAL
+ TEST_SCRIPT += h5repack_plugin.sh
+endif
+endif
+
+check_SCRIPTS=$(TEST_SCRIPT)
+
+# Depend on the hdf5 library, the tools library, the test library
+LDADD=$(LIBH5TOOLS) $(LIBH5TEST) $(LIBHDF5)
+
+testh5repack_detect_szip_SOURCES=testh5repack_detect_szip.c
+
+# Source files
+COMMON_SOURCES=../../src/h5repack/h5repack.c ../../src/h5repack/h5repack_copy.c ../../src/h5repack/h5repack_filters.c \
+ ../../src/h5repack/h5repack_opttable.c ../../src/h5repack/h5repack_parse.c ../../src/h5repack/h5repack_refs.c \
+ ../../src/h5repack/h5repack_verify.c
+h5repacktst_SOURCES=$(COMMON_SOURCES) h5repacktst.c
+
+
+if HAVE_SHARED_CONDITIONAL
+ # Build it as shared library if configure is enabled for shared library.
+ lib_LTLIBRARIES=libdynlibadd.la libdynlibvers.la
+ libdynlibadd_la_SOURCES=dynlib_rpk.c
+ libdynlibvers_la_SOURCES=dynlib_vrpk.c
+
+install-exec-hook:
+ $(RM) $(DESTDIR)$(libdir)/*dynlib*
+endif
+
+# Temporary files. *.h5 are generated by h5repack. They should
+# copied to the testfiles/ directory if update is required.
+CHECK_CLEANFILES+=*.h5 *.bin testfiles/h5diff_attr1.h5 testfiles/tfamily*.h5
+DISTCLEANFILES=h5repack.sh h5repack_plugin.sh
+
+include $(top_srcdir)/config/conclude.am