summaryrefslogtreecommitdiffstats
path: root/utils/tools/test/h5dwalk/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/tools/test/h5dwalk/CMakeLists.txt')
-rw-r--r--utils/tools/test/h5dwalk/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/utils/tools/test/h5dwalk/CMakeLists.txt b/utils/tools/test/h5dwalk/CMakeLists.txt
new file mode 100644
index 0000000..5f6c992
--- /dev/null
+++ b/utils/tools/test/h5dwalk/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required (VERSION 3.12)
+project (HDF5_TOOLS_TEST_H5DWALK)
+
+if (HDF5_BUILD_PARALLEL_TOOLS)
+ add_custom_command(
+ OUTPUT ${HDF5_TOOLS_DIR}/test/demo_destfiles.test
+ COMMAND bash -c ${HDF5_TOOLS_SRC_H5DWALK_SOURCE_DIR}/copy_demo_files.sh
+ ARGS ${HDF5_TOOLS_DIR}/test ${CMAKE_BINARY_DIR}/bin
+ DEPENDS ${HDF5_TOOLS_SRC_H5DWALK_SOURCE_DIR}/copy_demo_files.sh
+ )
+endif ()
+
+if (HDF5_TEST_TOOLS AND HDF5_TEST_SERIAL)
+ include (CMakeTests.cmake)
+endif ()