summaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorJan Engelhardt <jengelh@medozas.de>2009-06-22 23:12:53 (GMT)
committerJan Engelhardt <jengelh@medozas.de>2009-06-22 23:24:51 (GMT)
commitbf4fd3acee4e611afee20025f55454e37813f8ca (patch)
treed2bc642c03454626551adc86cb56f34e45530f2a /include/Makefile.am
parentef8ba32e0ca7ac7bbbaf87f6fd7b197af18aed25 (diff)
downloadlibnl-bf4fd3acee4e611afee20025f55454e37813f8ca.zip
libnl-bf4fd3acee4e611afee20025f55454e37813f8ca.tar.gz
libnl-bf4fd3acee4e611afee20025f55454e37813f8ca.tar.bz2
Move to automake-based build
Issues solved: * PACKAGE_VERSION was abused for SOVERSION * unneeded DEP stage * did not support out-of-tree builds * no way to turn off silent mode * overriding CFLAGS at make time was not supported * no static libs were provided Signed-off-by: Jan Engelhardt <jengelh@medozas.de>
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
new file mode 100644
index 0000000..cac5c24
--- /dev/null
+++ b/include/Makefile.am
@@ -0,0 +1,67 @@
+# -*- Makefile -*-
+
+nobase_include_HEADERS = \
+ netlink/fib_lookup/lookup.h \
+ netlink/fib_lookup/request.h \
+ netlink/genl/ctrl.h \
+ netlink/genl/family.h \
+ netlink/genl/genl.h \
+ netlink/genl/mngt.h \
+ netlink/netfilter/ct.h \
+ netlink/netfilter/log.h \
+ netlink/netfilter/log_msg.h \
+ netlink/netfilter/netfilter.h \
+ netlink/netfilter/nfnl.h \
+ netlink/netfilter/queue.h \
+ netlink/netfilter/queue_msg.h \
+ netlink/addr.h \
+ netlink/attr.h \
+ netlink/cache-api.h \
+ netlink/cache.h \
+ netlink/data.h \
+ netlink/errno.h \
+ netlink/handlers.h \
+ netlink/list.h \
+ netlink/msg.h \
+ netlink/netlink-compat.h \
+ netlink/netlink-kernel.h \
+ netlink/netlink.h \
+ netlink/object-api.h \
+ netlink/object.h \
+ netlink/route/cls/fw.h \
+ netlink/route/cls/police.h \
+ netlink/route/cls/u32.h \
+ netlink/route/link/info-api.h \
+ netlink/route/link/vlan.h \
+ netlink/route/sch/cbq.h \
+ netlink/route/sch/dsmark.h \
+ netlink/route/sch/fifo.h \
+ netlink/route/sch/htb.h \
+ netlink/route/sch/netem.h \
+ netlink/route/sch/prio.h \
+ netlink/route/sch/red.h \
+ netlink/route/sch/sfq.h \
+ netlink/route/sch/tbf.h \
+ netlink/route/addr.h \
+ netlink/route/class-modules.h \
+ netlink/route/class.h \
+ netlink/route/classifier-modules.h \
+ netlink/route/classifier.h \
+ netlink/route/link.h \
+ netlink/route/neighbour.h \
+ netlink/route/neightbl.h \
+ netlink/route/nexthop.h \
+ netlink/route/qdisc-modules.h \
+ netlink/route/qdisc.h \
+ netlink/route/route.h \
+ netlink/route/rtnl.h \
+ netlink/route/rule.h \
+ netlink/route/tc.h \
+ netlink/socket.h \
+ netlink/types.h \
+ netlink/utils.h \
+ netlink/version.h \
+ netlink-generic.h \
+ netlink-local.h \
+ netlink-tc.h \
+ netlink-types.h