summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2013-12-16 20:19:14 (GMT)
committerThomas Haller <thaller@redhat.com>2013-12-17 16:26:31 (GMT)
commit02c9c2518fb575594a00a6d6f42c0b93d8f93c84 (patch)
tree405c46b4475fb971476c802197b54892a350772e /lib/Makefile.am
parentd7aca17701519240bd69c0c6f7d55d0a09ce9346 (diff)
downloadlibnl-02c9c2518fb575594a00a6d6f42c0b93d8f93c84.zip
libnl-02c9c2518fb575594a00a6d6f42c0b93d8f93c84.tar.gz
libnl-02c9c2518fb575594a00a6d6f42c0b93d8f93c84.tar.bz2
build: fix build failure when using different build dir (make distcheck)
`make distcheck` builds outside the source directory using `../configure --srcdir=..`. This was broken because libnl.sym was expected in the $(top_srcdir) instead of $(top_builddir). Signed-off-by: Thomas Haller <thaller@redhat.com>
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index f96fc27..4a1e8d9 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -11,7 +11,7 @@ AM_CPPFLAGS = \
AM_LDFLAGS = \
-version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE) \
- -Wl,--version-script=$(top_srcdir)/libnl.sym
+ -Wl,--version-script=$(top_builddir)/libnl.sym
lib_LTLIBRARIES = \
libnl-3.la libnl-genl-3.la libnl-route-3.la libnl-nf-3.la libnl-idiag-3.la