summaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorThomas Graf <tgraf@suug.ch>2010-10-14 11:56:46 (GMT)
committerThomas Graf <tgraf@suug.ch>2010-10-14 11:56:46 (GMT)
commit3229b32e39363c439f0d042b561417e7b48aa786 (patch)
tree12072daf819eb7da0d91f7439df78a0371d85bdd /lib/Makefile.am
parent2dbc1ca76c5b82c40749e609eb83877418abb006 (diff)
downloadlibnl-3229b32e39363c439f0d042b561417e7b48aa786.zip
libnl-3229b32e39363c439f0d042b561417e7b48aa786.tar.gz
libnl-3229b32e39363c439f0d042b561417e7b48aa786.tar.bz2
- Prepare for 2.1.x tree
- Bump interface number, we will break API in the development tree
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
index 92a916e..ba64a99 100644
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -1,21 +1,19 @@
# -*- Makefile -*-
AM_CPPFLAGS = -Wall -I${top_srcdir}/include -I${top_builddir}/include -D_GNU_SOURCE -DSYSCONFDIR=\"$(sysconfdir)/libnl\"
+AM_LDFLAGS = -version-info 3:0:0
lib_LTLIBRARIES = \
libnl.la libnl-genl.la libnl-route.la libnl-nf.la
-libnl_la_LDFLAGS = -version-info 2:0:0
libnl_la_SOURCES = \
addr.c attr.c cache.c cache_mngr.c cache_mngt.c data.c doc.c \
error.c handlers.c msg.c nl.c object.c socket.c utils.c
-libnl_genl_la_LDFLAGS = -version-info 2:0:0
libnl_genl_la_LIBADD = libnl.la
libnl_genl_la_SOURCES = \
genl/ctrl.c genl/family.c genl/genl.c genl/mngt.c
-libnl_nf_la_LDFLAGS = -version-info 2:0:0
libnl_nf_la_LIBADD = libnl-route.la
libnl_nf_la_SOURCES = \
netfilter/ct.c netfilter/ct_obj.c netfilter/log.c \
@@ -35,7 +33,6 @@ route/pktloc_grammar.c: route/pktloc_grammar.l
route/pktloc_syntax.c: route/pktloc_syntax.y
$(YACC) -d $(YFLAGS) -o $@ $^
-libnl_route_la_LDFLAGS = -version-info 2:0:0
libnl_route_la_LIBADD = libnl.la
libnl_route_la_SOURCES = \
route/addr.c route/class.c route/class_api.c route/class_obj.c \